import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(_\\d+\\.dcm)$";
final String string = "Albert_Silva-MR11_13.dcm\n"
+ "Albert_Silva-MR11_13_22.dcm";
final String subst = "slice\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}