$re = '/(.*)(_\d+\.dcm)$/m';
$str = 'Albert_Silva-MR11_13.dcm
Albert_Silva-MR11_13_22.dcm';
$subst = "slice\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;