import re
regex = re.compile(r"(.*)(_\d+\.dcm)$", flags=re.MULTILINE)
test_str = ("Albert_Silva-MR11_13.dcm\n"
"Albert_Silva-MR11_13_22.dcm")
subst = "slice\\2"
result = regex.sub(subst, test_str)
if result:
print(result)