const regex = /(.*)(_\d+\.dcm)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(_\\d+\\.dcm)$', 'gm')
const str = `Albert_Silva-MR11_13.dcm
Albert_Silva-MR11_13_22.dcm`;
const subst = `slice\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);