import Foundation
let pattern = #"(.*)(_\d+\.dcm)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Albert_Silva-MR11_13.dcm
Albert_Silva-MR11_13_22.dcm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"slice\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)