re = /(.*)(_\d+\.dcm)$/m
str = 'Albert_Silva-MR11_13.dcm
Albert_Silva-MR11_13_22.dcm'
subst = 'slice\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result