import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0][0-9]{9}";
final String string = "qqqqqqqqqq\n"
+ "1111111111\n"
+ "345fg42356\n"
+ "43573457356735\n"
+ "fdrdsvgrevfc\n"
+ "0687897498";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}