import re
regex = re.compile(r"^[0][0-9]{9}", flags=re.MULTILINE)
test_str = ("qqqqqqqqqq\n"
"1111111111\n"
"345fg42356\n"
"43573457356735\n"
"fdrdsvgrevfc\n"
"0687897498")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")