const regex = /^[0][0-9]{9}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0][0-9]{9}', 'gm')
const str = `qqqqqqqqqq
1111111111
345fg42356
43573457356735
fdrdsvgrevfc
0687897498`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}