re = /^[0][0-9]{9}/m
str = 'qqqqqqqqqq
1111111111
345fg42356
43573457356735
fdrdsvgrevfc
0687897498'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end