// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0][0-9]{9}").unwrap();
let string = "qqqqqqqqqq
1111111111
345fg42356
43573457356735
fdrdsvgrevfc
0687897498";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}