#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(0[1-9]|1[012])[\\\/](0[1-9]|[12][0-9]|3[01])[\\\/](19|20)\d\d"
Local $sString = "Cheesy Dibbles\n\n\n12/31/2011\n\n0 Comments\n\nThe cheese is left unspoken."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")