using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(0[1-9]|1[012])[\\\/](0[1-9]|[12][0-9]|3[01])[\\\/](19|20)\d\d";
string input = @"Cheesy Dibbles\n\n\n12/31/2011\n\n0 Comments\n\nThe cheese is left unspoken.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}