$re = '/(0[1-9]|1[012])[\\\\\/](0[1-9]|[12][0-9]|3[01])[\\\\\/](19|20)\d\d/';
$str = 'Cheesy Dibbles\\n\\n\\n12/31/2011\\n\\n0 Comments\\n\\nThe cheese is left unspoken.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);