re = /(0[1-9]|1[012])[\\\/](0[1-9]|[12][0-9]|3[01])[\\\/](19|20)\d\d/
str = 'Cheesy Dibbles\\n\\n\\n12/31/2011\\n\\n0 Comments\\n\\nThe cheese is left unspoken.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end