#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[A-Za-z0-9 ']*(?:(?:~~|&&)[A-Za-z0-9 ']*)*\K(?:[^A-Za-z0-9 ']|\z)"
Local $sString = "I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh" & @CRLF & _
"" & @CRLF & _
"a~&a"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)