$re = '/[A-Za-z0-9 \']*(?:(?:~~|&&)[A-Za-z0-9 \']*)*\K(?:[^A-Za-z0-9 \']|\z)/';
$str = 'I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh
a~&a';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;