import Foundation
let pattern = #"[A-Za-z0-9 ']*(?:(?:~~|&&)[A-Za-z0-9 ']*)*\K(?:[^A-Za-z0-9 ']|\z)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh
a~&a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)