import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z0-9 ']*(?:(?:~~|&&)[A-Za-z0-9 ']*)*\\K(?:[^A-Za-z0-9 ']|\\z)";
final String string = "I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh\n\n"
+ "a~&a";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}