const regex = /[A-Za-z0-9 ']*(?:(?:~~|&&)[A-Za-z0-9 ']*)*\K(?:[^A-Za-z0-9 ']|\z)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z0-9 \']*(?:(?:~~|&&)[A-Za-z0-9 \']*)*\\K(?:[^A-Za-z0-9 \']|\\z)', 'g')
const str = `I like~~cake~too&&m~~~~u~~~~~ch&now.~~~gh
a~&a`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);