package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d+),0,'(([^']|\\')+)',0`)
var str = `(500,0,'ABC',4),(550,0,'ABC',0),(450,0,'D\'E,F',0),(650,0,'G_HI',0);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}