$re = '/\((\d+),0,\'(([^\']|\\\\\')+)\',0/';
$str = '(500,0,\'ABC\',4),(550,0,\'ABC\',0),(450,0,\'D\\\'E,F\',0),(650,0,\'G_HI\',0);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);