re = /\((\d+),0,'(([^']|\\')+)',0/
str = '(500,0,\'ABC\',4),(550,0,\'ABC\',0),(450,0,\'D\\\'E,F\',0),(650,0,\'G_HI\',0);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end