use strict;
my $str = '(500,0,\'ABC\',4),(550,0,\'ABC\',0),(450,0,\'D\\\'E,F\',0),(650,0,\'G_HI\',0);';
my $regex = qr/\((\d+),0,'(([^']|\\')+)',0/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}