import re
regex = re.compile(r"\((\d+),0,'(([^']|\\')+)',0")
test_str = "(500,0,'ABC',4),(550,0,'ABC',0),(450,0,'D\\'E,F',0),(650,0,'G_HI',0);"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")