#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$"
Local $sString = "+13178696932" & @CRLF & _
"3178696932" & @CRLF & _
"13178696932" & @CRLF & _
"11231234" & @CRLF & _
"1231234" & @CRLF & _
"3178696932" & @CRLF & _
"8696932" & @CRLF & _
"317-869-6932" & @CRLF & _
"+1(317)869-6932" & @CRLF & _
"+1 (317)869-6932" & @CRLF & _
"+033178696932" & @CRLF & _
"13178696932" & @CRLF & _
"23178696932" & @CRLF & _
"+43 720 884555" & @CRLF & _
"+1 317 869 6932" & @CRLF & _
"317-869-6932" & @CRLF & _
"+1(317)869-6932" & @CRLF & _
"+1317123456" & @CRLF & _
"(317) 869-6932" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"+1(555) 555-5555" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")