// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$").unwrap();
let string = "+13178696932
3178696932
13178696932
11231234
1231234
3178696932
8696932
317-869-6932
+1(317)869-6932
+1 (317)869-6932
+033178696932
13178696932
23178696932
+43 720 884555
+1 317 869 6932
317-869-6932
+1(317)869-6932
+1317123456
(317) 869-6932
(555) 555-5555
+1(555) 555-5555
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}