import Foundation
let pattern = #"^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+13178696932
3178696932
13178696932
11231234
1231234
3178696932
8696932
317-869-6932
+1(317)869-6932
+1 (317)869-6932
+033178696932
13178696932
23178696932
+43 720 884555
+1 317 869 6932
317-869-6932
+1(317)869-6932
+1317123456
(317) 869-6932
(555) 555-5555
+1(555) 555-5555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)