use strict;
my $str = '+13178696932
3178696932
13178696932
11231234
1231234
3178696932
8696932
317-869-6932
+1(317)869-6932
+1 (317)869-6932
+033178696932
13178696932
23178696932
+43 720 884555
+1 317 869 6932
317-869-6932
+1(317)869-6932
+1317123456
(317) 869-6932
(555) 555-5555
+1(555) 555-5555
';
my $regex = qr/^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}