# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$"
test_str = ("+13178696932\n"
"3178696932\n"
"13178696932\n"
"11231234\n"
"1231234\n"
"3178696932\n"
"8696932\n"
"317-869-6932\n"
"+1(317)869-6932\n"
"+1 (317)869-6932\n"
"+033178696932\n"
"13178696932\n"
"23178696932\n"
"+43 720 884555\n"
"+1 317 869 6932\n"
"317-869-6932\n"
"+1(317)869-6932\n"
"+1317123456\n"
"(317) 869-6932\n"
"(555) 555-5555\n"
"+1(555) 555-5555\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.