using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"feed the (cat|dog|bear)";
string input = @"""feed the cat.""
""feed the dog.""
""feed the bear.""
""feed the eagle.""
""feed the monkey.""
""feed the donkey.""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}