// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)feed the (cat|dog|bear)").unwrap();
let string = "\"feed the cat.\"
\"feed the dog.\"
\"feed the bear.\"
\"feed the eagle.\"
\"feed the monkey.\"
\"feed the donkey.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}