package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)feed the (cat|dog|bear)`)
var str = `"feed the cat."
"feed the dog."
"feed the bear."
"feed the eagle."
"feed the monkey."
"feed the donkey."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}