re = /feed the (cat|dog|bear)/m
str = '"feed the cat."
"feed the dog."
"feed the bear."
"feed the eagle."
"feed the monkey."
"feed the donkey."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end