const regex = /feed the (cat|dog|bear)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('feed the (cat|dog|bear)', 'gm')
const str = `"feed the cat."
"feed the dog."
"feed the bear."
"feed the eagle."
"feed the monkey."
"feed the donkey."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}