# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\\/?[^b]*?>//gm;t' <<< "My awesome <b>thing!</b> is not <i>italic</i>."