$re = '/<\/?[^b]*?>/m';
$str = 'My awesome <b>thing!</b> is not <i>italic</i>.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;