use strict;
my $str = 'My awesome <b>thing!</b> is not <i>italic</i>.';
my $regex = qr/<\/?[^b]*?>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";