const regex = /<\/?[^b]*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?[^b]*?>', 'gm')
const str = `My awesome <b>thing!</b> is not <i>italic</i>.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);