using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((main\.)?(\w)+\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})";
string substitution = @"\1";
string input = @"favicon.ico
main.somestringwithcharacterandletters.css
main.somestringwithcharacterandletters.js
somestringwithcharactersandletters.woff
somestringwithcharactersandletter.ttf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}