$re = '/((main\.)?(\w)+\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})/m';
$str = 'favicon.ico
main.somestringwithcharacterandletters.css
main.somestringwithcharacterandletters.js
somestringwithcharactersandletters.woff
somestringwithcharactersandletter.ttf';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;