const regex = /((main\.)?(\w)+\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((main\\.)?(\\w)+\\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})', 'gm')
const str = `favicon.ico
main.somestringwithcharacterandletters.css
main.somestringwithcharacterandletters.js
somestringwithcharactersandletters.woff
somestringwithcharactersandletter.ttf`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);