import Foundation
let pattern = #"((main\.)?(\w)+\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
favicon.ico
main.somestringwithcharacterandletters.css
main.somestringwithcharacterandletters.js
somestringwithcharactersandletters.woff
somestringwithcharactersandletter.ttf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)