import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((main\\.)?(\\w)+\\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})";
final String string = "favicon.ico\n"
+ "main.somestringwithcharacterandletters.css\n"
+ "main.somestringwithcharacterandletters.js\n"
+ "somestringwithcharactersandletters.woff\n"
+ "somestringwithcharactersandletter.ttf";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}