// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((main\.)?(\w)+\.(?:css|js|woff|woff2|eot|ttf|png|ico){1})").unwrap();
let string = "favicon.ico
main.somestringwithcharacterandletters.css
main.somestringwithcharacterandletters.js
somestringwithcharactersandletters.woff
somestringwithcharactersandletter.ttf";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}