#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)news/(?P<issue_number>[^\\./]+)\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\.\d+)?(\.[^\\./]+)*\.rst$"
Local $sString = "news/truststore.vendor.rst" & @CRLF & _
"" & @CRLF & _
"news/12771.feature.rst" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")