package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)news/(?P<issue_number>[^\\./]+)\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\.\d+)?(\.[^\\./]+)*\.rst$`)
var str = `news/truststore.vendor.rst
news/12771.feature.rst
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}