import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "news/(?P<issue_number>[^\\\\./]+)\\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\\.\\d+)?(\\.[^\\\\./]+)*\\.rst$";
final String string = "news/truststore.vendor.rst\n\n"
+ "news/12771.feature.rst\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}