const regex = new RegExp('news/(?P<issue_number>[^\\\\./]+)\\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\\.\\d+)?(\\.[^\\\\./]+)*\\.rst$', 'gm')
const str = `news/truststore.vendor.rst
news/12771.feature.rst
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}