using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"news/(?P<issue_number>[^\\./]+)\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\.\d+)?(\.[^\\./]+)*\.rst$";
string input = @"news/truststore.vendor.rst
news/12771.feature.rst
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}